TriumphPay Audit: Degraded services with some invoice exports and imports.
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Sep 11, 2023 - 17:00 EDT
Identified
We are experiencing degraded services exporting and importing some invoices due to degraded services with a 3rd party vendor. We are attempting retries to push work through, but there will be some delays.
Posted Sep 11, 2023 - 15:58 EDT
This incident affected: Email Imports and Invoice exports.