503 Error displaying Intermittently

Incident Report for TriumphPay

Monitoring

A fix has been implemented restoring access we are continuing to monitor.
Posted Aug 27, 2026 - 14:24 EDT

Investigating

We are investigating an issue where the audit application is currently inaccessible and showing a 503 error. The team is engaged and working to identify and resolve the issue.
Posted Aug 27, 2026 - 14:14 EDT
This incident affects: Website.