TriumphPay Audit: Loads Displaying Errors

Incident Report for TriumphPay

Resolved

This issue has been resolved, if you’ll please perform a full refresh by pressing either CTRL R (Windows) or CMD R (Mac), you should see a return to expected performance.
Posted Dec 01, 2023 - 10:00 EST

Investigating

We are aware of an issue which is causing errors to display within TriumphPay Audit, our engineering team is currently investigating and working to resolve the issue.
Posted Dec 01, 2023 - 09:45 EST
This incident affected: Website.