Presence Notifications not working

Incident Report for TriumphPay

Update

We are continuing to monitor for any further issues.
Posted Mar 12, 2026 - 11:30 EDT

Monitoring

We are continuing to monitor this service, as the presence notifications have been restored. However, services have not been fully restored at this time. We will update again when this is fully resolved or if services have degraded.
Posted Mar 12, 2026 - 11:30 EDT

Identified

We are currently aware of the presence notifications in the TriumphPay Audit application not functioning properly. We have identified the issue and are working towards resolution.
Posted Mar 11, 2026 - 15:47 EDT
This incident affects: Website.