503 Error displaying Intermittently

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 11:21 EDT

Monitoring

A fix was implemented and services restored. We are continuing to monitor.
Posted Aug 13, 2026 - 10:51 EDT

Investigating

We are currently investigating an issue where some users are unable to access the platform and receiving a 503 error.
Posted Aug 13, 2026 - 10:29 EDT
This incident affected: Website.