Fed Reserve Nationwide ACH Delay

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 10:10 EST

Monitoring

The Federal Reserve is currently experiencing a nationwide delay on incoming and outgoing ACH payments for all financial institutions. We are closely monitoring the situation and will keep you updated as the situation progresses. Wire transfers are unaffected and still available.
Posted Mar 03, 2026 - 17:23 EST