Triumph Audit: Delayed Email Imports

Incident Report for TriumphPay

Resolved

This incident has been resolved
Posted Aug 05, 2025 - 17:32 EDT

Monitoring

The issue has been resolved; while we are waiting for imports to catch-up, document batch grouping has returned to expected performance.
Posted Aug 05, 2025 - 15:43 EDT

Update

While we are continuing to investigate delayed email imports into Audit, some users have experienced error messages when attempting to group documents; this is being investigated concurrently.
Posted Aug 05, 2025 - 15:07 EDT

Investigating

Audit is experiencing some delayed email imports and we are actively investigating.
Posted Aug 05, 2025 - 14:49 EDT
This incident affected: Email Imports.