Triumph Audit: Logging In

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 09:49 EST

Investigating

We have been notified of a number of users experiencing issues logging into the audit platform. We are currently investigating this issue.
Posted Dec 15, 2025 - 09:22 EST
This incident affected: Website.