Latency sending invoices to FactorSoft

Incident Report for TriumphPay

Update

We are continuing to investigate this issue.
Posted Mar 05, 2026 - 10:15 EST

Investigating

We are seeing sporadic delays transferring files between Audit and FactorSoft/JackHenry. We are currently investigating and working with JackHenry, and will provide updates soon.
Posted Mar 05, 2026 - 09:57 EST
This incident affects: Invoice exports.