Core (Payments Unavailable)
Incident Report for TriumphPay
Resolved
TriumphPay Payments is up and running
Posted Jul 19, 2024 - 07:50 EDT
Monitoring
We have recovered all services and are monitoring
Posted Jul 19, 2024 - 04:56 EDT
Identified
TriumphPay Core Payments is unavailable due to a global issue caused by a vendor. We are working on a fix at this time
Posted Jul 19, 2024 - 03:55 EDT
Investigating
We are currently investigating this issue.
Posted Jul 19, 2024 - 03:54 EDT
This incident affected: Website.