TriumphPay Audit: Please Wait Notification

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Jan 27, 2025 - 11:32 EST

Identified

Some Audit users are experiencing the notification "Please Wait" when attempting to access loads or process invoices. The cause of this has been identified and an update is being implemented.
Posted Jan 27, 2025 - 10:37 EST
This incident affected: Website.