Data Imports
Incident Report for TriumphPay
Resolved
The incident impacting TriumphPay Audit data imports has been resolved.
Posted Jul 21, 2022 - 15:38 EDT
Monitoring
The issues contributing to delayed data imports has been identified and we are monitoring as imports are recovering.
Posted Jul 21, 2022 - 15:20 EDT
Investigating
TriumphPay Audit customers may experience delays with data imports; we are currently investigating and will update as additional information becomes available.
Posted Jul 21, 2022 - 15:02 EDT
This incident affected: Data Import.