TriumphPay Audit: Invoice Presence Detection is not working
Incident Report for TriumphPay
Resolved
The issue is now resolved.
Posted Sep 07, 2023 - 09:29 EDT
Investigating
Identifying if another user is already working on an invoice is not currently working. We are investigating the issue.
Posted Sep 06, 2023 - 12:07 EDT
This incident affected: Website.