Payments: Some Carriers Experiencing Difficulties Submitting Paperwork

Incident Report for TriumphPay

Resolved

Services have been restored; carrier documents should upload correctly and most delayed transmissions are processing as normal through the queue. We are investigating any impacted outgoing files that did not properly queue to manually resend.
Posted Nov 27, 2023 - 19:18 EST

Update

This issue is still ongoing; in further research of the issue we discovered that this is also delaying certain external file delivery.
Posted Nov 27, 2023 - 15:44 EST

Investigating

We have identified an issue with certain carriers having issues sending documents through the application. We are currently working towards resolution and appreciate your patience.
Posted Nov 27, 2023 - 14:49 EST
This incident affected: Website.