TriumphPay Audit: Delayed Email Imports
Incident Report for TriumphPay
Resolved
We have received notification that the inbound delays have been resolved and emails should be arriving as anticipated now.
Posted May 05, 2022 - 11:55 EDT
Identified
We have received notification that our email vendor has identified the cause of the inbound delays and they are actively working on implementing a fix. We will continue to update as additional information is received.
Posted May 05, 2022 - 11:42 EDT
Investigating
TriumphPay Audit has received notification from our email vendor that inbound emails are currently being delayed. While we do not have an estimate on the resolution time, we will continue to update as we receive additional information.
Posted May 05, 2022 - 11:29 EDT
This incident affected: Email Imports.