Triumph: Import and Export Delays

Incident Report for TriumphPay

Resolved

The AWS outage impacting Triumph services has been resolved.
Posted Oct 21, 2025 - 09:33 EDT

Identified

Several services are being impacted by the global AWS outage.
You can monitor the status here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:59 EDT

Investigating

We are currently seeing delays with imports and exports, we are actively investigating.
Posted Oct 20, 2025 - 09:40 EDT
This incident affected: Email Imports and Invoice exports.