Inability to load certain document packages
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 12:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 02, 2024 - 12:46 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 02, 2024 - 12:46 EDT
Investigating
The team is currently engaged in investigating an issue with specific factor accounts not able to load certain document submissions.
Posted Oct 02, 2024 - 12:24 EDT
This incident affected: Website and Data Import.