Email Imports Delayed

Incident Report for TriumphPay

Resolved

The import delays have caught up and the incident is now resolved.
Posted Dec 09, 2025 - 13:07 EST

Monitoring

We are monitoring a situation where a slight delay to email imports has occurred. The latency appears to have resolved at this time, however the system is currently catching up from the delay.
Posted Dec 09, 2025 - 12:47 EST
This incident affected: Email Imports.