MFA Push Notifications

Incident Report for TriumphPay

Resolved

We have received notification that this incident has been resolved and users should begin receiving SMS notifications as anticipated once again.
Posted Apr 22, 2025 - 10:11 EDT

Investigating

Some TriumphPay and TriumphPay Audit users who have Multi-Factor Authentication being received by SMS are not receiving these notifications. We are actively communicating with our vendor regarding this incident.

In the interim, users who are using OKTA Verify for their authentication service can use push notifications to log in.
Posted Apr 22, 2025 - 09:34 EDT
This incident affected: Website.