Triumph Audit: Slow Email Imports

Incident Report for TriumphPay

Resolved

This incident is resolved.
Posted Aug 01, 2025 - 17:24 EDT

Monitoring

A resolution for the slow email imports has been released and we are monitoring.
Posted Aug 01, 2025 - 16:51 EDT

Identified

Audit is experiencing an issue with slow email imports; the cause has been identified and we are actively working toward resolution.
Posted Aug 01, 2025 - 16:15 EDT
This incident affected: Email Imports.