Triumph Audit: Unable to Ignore Submissions

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 12:10 EDT

Identified

Triumph Audit users are experiencing an issue where they are unable to ignore submissions and merge emails.

We have identified the cause and are in the process of pushing a fix.
Posted Apr 28, 2026 - 11:46 EDT
This incident affected: Website.