HubTran Unavailable
Incident Report for TriumphPay
Resolved
This issue has been identified and resolved. HubTran is now available.
Posted Oct 12, 2020 - 10:23 EDT
Investigating
HubTran is currently experiencing issues causing it to be unavailable. We are investigating.
Posted Oct 12, 2020 - 10:17 EDT
This incident affected: Email Imports and Website.