TriumphPay Delays
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 14:06 EDT
Update
The slowness experienced by TriumphPay has been resolved and you should see a return to expected performance.
Posted Jun 22, 2023 - 14:06 EDT
Monitoring
The slowness has been identified as transient with TriumphPay and we are investigating the root cause.
Posted Jun 22, 2023 - 11:42 EDT
Investigating
TriumphPay is currently experiencing slowness, we are investigating.
Posted Jun 22, 2023 - 11:28 EDT
This incident affected: Website.