Delays Sending to Approved Invoices to Aljex

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Feb 03, 2021 - 14:21 EST

Investigating

HubTran has been made aware that Aljex users may experience delays sending approved invoices, however Descartes is currently investigating. We will update when we have additional information.
Posted Feb 03, 2021 - 13:14 EST