Triumph: SFTP Connection Issues

Incident Report for TriumphPay

Resolved

We have released a revert for the maintenance update that was done yesterday and are seeing normal functionality for the SFTP at this time.

If you are still experiencing any abnormality, please reach out through our support portal:
https://paymentshelp.triumph.io/support/tickets/new
Posted Jul 31, 2025 - 14:45 EDT

Investigating

Some Triumph clients are experiencing difficulties connecting to our SFTP server, we are actively investigating.
Posted Jul 31, 2025 - 13:07 EDT
This incident affected: Data Import.