Triumph Support Delays

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 18:07 EDT

Investigating

Triumph is currently experiencing some network issues; while Audit and TriumphPay are both working as anticipated, support will be delayed.
Posted Jun 26, 2025 - 16:30 EDT
This incident affected: Website.