Portal Uploads Unavailable

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Feb 11, 2021 - 08:16 EST

Investigating

HubTran has received a report that our vendor is experiencing network issues which are causing Portal Uploads to be unavailable. They are investigating and we will follow up as soon as we have received additional information.
Posted Feb 10, 2021 - 15:36 EST