Email Delays
Incident Report for TriumphPay
Resolved
This issue has now been resolved.
Posted Dec 16, 2020 - 16:51 EST
Monitoring
Email delays which we were experiencing have improved and we are currently monitoring.
Posted Dec 16, 2020 - 16:49 EST
Identified
HubTran is currently experiencing an issue where emails may be delayed. We are aware of the issue and working to catch these items up. We will update as soon as this has been resolved.
Posted Dec 16, 2020 - 15:37 EST
This incident affected: Email Imports.