TriumphPay Audit: Email Import Delays

Incident Report for TriumphPay

Resolved

The email import delays have been resolved and you should see a return to expected performance.
Posted Jul 03, 2024 - 10:10 EDT

Monitoring

TriumphPay Audit's email vendor experienced sending delays this morning. While we are seeing emails successfully import, you may see some slowness; we are continuing to monitor.
Posted Jul 03, 2024 - 10:02 EDT
This incident affected: Email Imports.