TriumphPay Carrier Portal: Inability for carriers to login.
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Sep 11, 2023 - 14:26 EDT
Monitoring
Carriers should now be able to login to the TriumphPay Carrier Portal. We will monitor.
Posted Sep 11, 2023 - 14:23 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 11, 2023 - 14:20 EDT
Investigating
We are currently investigating this issue.
Posted Sep 11, 2023 - 14:20 EDT
This incident affected: Website.