Audit: Errors When Processing Invoices
Incident Report for TriumphPay
Resolved
The incident which resulted in some TriumphPay Audit Factor users receiving an error message when processing loads has been resolved.

If you were impacted by this, please clear your browser cache and close all browser windows. Upon relaunching Audit, you should see a return to expected performance.
Posted Feb 13, 2024 - 15:21 EST
Identified
We have identified the issue which is causing some Factors to receive an error message when processing invoices; a fix is being implemented and we will continue to update as additional information becomes available.
Posted Feb 13, 2024 - 15:10 EST
Investigating
Some TriumphPay Audit users are receiving an error when attempting to process invoices . We are actively investigating and will update as additional information becomes available.
Posted Feb 13, 2024 - 14:57 EST
This incident affected: Website.