HubTran Email Delays
Incident Report for TriumphPay
Resolved
Our email vendor has advised that all inbound processing delays are completely caught up and the incident is now resolved. Thank you for your patience!
Posted Oct 29, 2021 - 16:51 EDT
Identified
Our email provider has located the issue and are currently implementing a fix. The inbound processing delay is improving and we will continue to provide updates as they are received.
Posted Oct 29, 2021 - 16:10 EDT
Update
Our email provider has confirmed they are investigating an issue on their side which is affecting our email processing. Emails are being processed, but at a delay. We will continue to update this page as we receive updates.
Posted Oct 29, 2021 - 16:01 EDT
Investigating
We are currently investigating delays with emails reaching HubTran, we will update as soon as we are able.
Posted Oct 29, 2021 - 15:34 EDT
This incident affected: Email Imports.