Our email provider reported that the issue is resolved. Email imports into Audit are back to normal.
Posted Oct 14, 2022 - 18:33 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 14, 2022 - 18:29 EDT
Monitoring
Our email imports appear to be caught up, but we are waiting for confirmation from our email provider to resolve the issue.
Posted Oct 14, 2022 - 17:26 EDT
Update
We're continuing to see improvement in email imports. Emails are still delayed, but we appear to be catching up quickly.
Posted Oct 14, 2022 - 16:34 EDT
Update
Our email provider is reporting that they have identified the issue and things should be improving. We are continuing to monitor it on our side.
Posted Oct 14, 2022 - 16:07 EDT
Identified
Our email provider is currently experiencing delays sending emails to TriumphPay Audit, and as a result, new emails may be slow to show up in your Audit account.