Core (Payments) login issues
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Nov 29, 2023 - 10:58 EST
Identified
We are aware users are currently having issues with logging into the Core (Payments) application. The issue is currently being investigated.
Posted Nov 29, 2023 - 10:56 EST
This incident affected: Website.