Triumph Audit: Import Failures and Page Duplication Issues

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 18:15 EDT

Monitoring

The fix has been placed into Production and we are Monitoring.
Posted Mar 23, 2026 - 17:41 EDT

Identified

Audit is experiencing an issue where some imports are failing and the button to duplicate pages within the User Interface is not consistently working at this time. The issue has been identified and a fix is being put into Production.
Posted Mar 23, 2026 - 16:47 EDT
This incident affected: Email Imports and Website.