TriumphPay Audit: Please Contact Support Error
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 14:44 EDT
Monitoring
The fix has been implemented and you should begin to see a return to expected performance.
Posted Mar 20, 2024 - 14:31 EDT
Identified
We have identified the cause of the Audit outage and we are currently deploying a fix. We will continue to update as additional information becomes available.
Posted Mar 20, 2024 - 14:22 EDT
Investigating
TriumphPay Audit is failing to load and instead providing a "Please contact support" error, we are actively investigating and will update as additional information becomes available.
Posted Mar 20, 2024 - 14:08 EDT
This incident affected: Website.