MFA Text and Phone delays

Incident Report for TriumphPay

Resolved

We are continuing to monitor for any further issues.
Posted Dec 01, 2025 - 10:14 EST

Update

We are continuing to monitor for any further issues.
Posted Dec 01, 2025 - 10:14 EST

Monitoring

We have been notified of an ongoing issue with certain cell providers causing long delays in notification text for MFA to Call and Text. This does not impact users using other MFA options.
Posted Nov 28, 2025 - 14:17 EST
This incident affected: Website.