503/504 Error

Incident Report for TriumphPay

Resolved

The Email Imports are now caught up, this incident is resolved.
Posted Mar 31, 2025 - 16:07 EDT

Monitoring

The issue impacting Audit has been resolved and we are monitoring.
We are still experiencing some delays with Email Imports, however they are in the process of catching up.
Posted Mar 31, 2025 - 15:18 EDT

Investigating

Our team is aware of an issue currently impacting traffic to the audit platform. The team is current investigating and working to restore services as quickly as possible.
Posted Mar 31, 2025 - 14:55 EDT
This incident affected: Email Imports, Website, Invoice exports, and Data Import.