TriumphPay Audit: Website slowness, email imports may be delayed
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Sep 08, 2023 - 12:30 EDT
Update
We're still slightly behind on processing images for new email imports, but any slowness issues with the website are resolved.
Posted Sep 08, 2023 - 12:21 EDT
Update
We are continuing to monitor the application—image processing is still delayed, so thumbnails may be delayed in appearing.
Posted Sep 08, 2023 - 12:11 EDT
Monitoring
We have implemented a fix and are currently monitoring the application. Email imports may still be delayed, and the app might continue to operate slowly while we recover.
Posted Sep 08, 2023 - 11:46 EDT
Identified
In addition to email imports being slow, TriumphPay Audit is also returning exceptions and is inaccessible for most users. We have identified the issue and are working on a fix.
Posted Sep 08, 2023 - 11:41 EDT
Investigating
TriumphPay Audit: Some email imports may be delayed due to documents not displaying. We are actively investigating.
Posted Sep 08, 2023 - 10:48 EDT
This incident affected: Email Imports and Website.