Audit application intermittently unavailable

Incident Report for TriumphPay

Update

Issue has resurfaced, the team is working on resolution.
Posted Aug 05, 2026 - 14:57 EDT

Monitoring

Service is restored we are actively monitoring.
Posted Aug 05, 2026 - 13:43 EDT

Identified

We are aware of an issue where users may be seeing a 503 error when attempting to access the audit application. The team is engaged and working towards resolution.
Posted Aug 05, 2026 - 13:37 EDT
This incident affects: Website.