TriumphPay Latency
Incident Report for TriumphPay
Resolved
The previously identified latency is now resolved and TriumphPay has returned to expected performance.
Posted Jun 13, 2023 - 18:46 EDT
Identified
We are seeing increased errors and latency due to issues with our hosting provider.
Posted Jun 13, 2023 - 16:03 EDT
This incident affected: Email Imports, Website, Invoice exports, and Data Import.