HubTran Performance Degradation
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 13:26 EST
Monitoring
HubTran performance issues are clearing and performance is now returning to its normal state. We will continue to monitor this.
Posted Jan 12, 2021 - 12:53 EST
Investigating
HubTran is currently experiencing slowness and login issues. We are investigating the cause.
Posted Jan 12, 2021 - 12:40 EST
This incident affected: Website.