Delayed TriumphPay Payments Imports

Incident Report for TriumphPay

Resolved

This incident has been resolved and TriumphPay Payments imports have returned to expected performance.
Posted Aug 25, 2023 - 10:00 EDT

Update

The incident which contributed to the delayed imports has been resolved and we are continuing to monitor as the remaining imports are cleared.
Posted Aug 24, 2023 - 17:54 EDT

Monitoring

TriumphPay has released a fix and we will continue to monitor as the delayed imports are cleared.
Posted Aug 24, 2023 - 16:57 EDT

Identified

TriumphPay is aware of delays with the importing of data into the Payments application and we are actively working towards resolution. Additional updates will be shared as they become available.
Posted Aug 24, 2023 - 15:14 EDT
This incident affected: Invoice exports.