TriumphPay Audit: Annotation Toolbar
Incident Report for TriumphPay
Resolved
This incident is now resolved.
Posted Apr 26, 2024 - 14:30 EDT
Identified
We are aware that the Annotation toolbar within Audit is unable to be utilized and we are implementing a fix.
We expect to see a return to expected performance shortly.
Posted Apr 26, 2024 - 14:15 EDT
This incident affected: Website.