TriumphPay Audit and MercuryGate Delays

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Feb 21, 2023 - 10:59 EST

Update

This has been resolved and all systems are operational.
Posted Feb 03, 2023 - 08:31 EST

Monitoring

We have received notification that a patch has been implemented and the situation is currently being monitored.

We will continue to provide additional information as it becomes available.
Posted Feb 02, 2023 - 20:00 EST

Investigating

Incoming data from MercuryGate and outgoing data from TriumphPay Audit may be delayed.

MercuryGate is currently investigating and we will update as additional information becomes available.
Posted Feb 02, 2023 - 16:58 EST
This incident affected: Invoice exports and Data Import.