TriumphPay Audit Unavailable
Incident Report for TriumphPay
Resolved
This incident has been resolved.
Posted Aug 07, 2023 - 08:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2023 - 08:15 EDT
Investigating
TriumphPay Audit will be unavailable for 15 minutes starting at 7:10AM Central time.
Posted Aug 07, 2023 - 08:10 EDT
This incident affected: Website.