Degraded Performance
Incident Report for TriumphPay
Resolved
Issues causing performance degradation to HubTran have been resolved and users should see a return to normal response times.
Posted Sep 08, 2020 - 13:40 EDT
Investigating
HubTran is currently experiencing performance issues which may cause pages to load slowly. We are investigating this issue and working on a resolution.
Posted Sep 08, 2020 - 12:10 EDT
This incident affected: Email Imports and Website.