Issues with Carrier Portal and submitting documents
Incident Report for TriumphPay
Resolved
Issue has been resolved. Service has returned to normal.
Posted Nov 19, 2024 - 15:45 EST
Investigating
We are currently investigating an issue where users are unable to upload documents to the carrier portal. This is impacting both the web and mobile versions.
Posted Nov 19, 2024 - 14:25 EST
This incident affected: Website.