Triumph Audit: Slow Email Imports

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 19:07 EDT

Identified

Emails are currently importing into Audit slower than usual, we are working on restoring to expected service levels.
Posted Jul 30, 2025 - 17:16 EDT
This incident affected: Email Imports.