Phone and Text Delays for MFA

Incident Report for TriumphPay

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 10:28 EST

Identified

We have been notified of an ongoing issue with certain cell providers causing long delays in notification text for MFA to Call and Text. This does not impact users using other MFA options.
Posted Dec 01, 2025 - 16:03 EST
This incident affected: Website.